USB GPS for PI4 - Cloud

I feel bad for my 3rd post to the forum. I appreciate the time it takes for the advice. My last items on my list is getting a USB GPS dongle working on the PI4 so I can have my LOC input for the cloud mapper. I have followed every tutorial online and have come up dry. The PI sees the Ublox device. Installed GPSD and modified the file. It appears to be getting some info, but almost seems like it is the wrong baudrate or data format. Confirmed a good RX… as when I plug into my laptop, it picks up no issues. Has anyone used one of these small dongles or can you recommend one for a transportable case?

Issue is resolved. This helped me for anyone else having the issue:

What was the issue specifically if you don’t mind sharing?

The GPS (plugged directly in) would show up as ttyACM0. It seemed to conflict with the KRAKEN. It would often lock up. If I would stop the Kraken from RX, the GPS would receive on the GUI. Sometimes it would conflict and make the gain max on the kraken. Almost seemed like both were using the same ports.

One day the GPS went to ttyACMO and it worked better. Still having some issues though. The Cloud Mapper still shows a static location even though the Kraken GUI is showing a running GPS lat/long. Still working through that.


Looks like I have some data to report. Kraken seems to have a delayed start or no start if the GPS is plugged into any of the USB ports on boot. (2 different GPS styles). If I let the Kraken boot, start sampling, then plug the GPS in, the GUI recognizes it and it reports to the cloud mapper as expected. As soon as I change any setting on the Kraken, it all starts to conflict. Kraken goes into overdrive and gain settings act weird- you can see its thinking some of the GPS data is causing issues. If I unplug the USB GPS, all starts working normally again on the Kraken. Seems like the Kraken and the USB are fighting for ports. Hope that helps. I am running the latest version and tried two different style USB GPS units.

Hm weird, a GPS shouldn’t be using up a lot of bandwidth. I know that if you plug something like a WiFi dongle or a USB memory stick in and transfer data, Kraken can end up dropping samples and loosing coherence due to the USB bandwidth limitations being exceeded. But GPS shouldn’t be transferring that much data.

I’m using a GN-803G USB GPS in my tests without issue. Maybe only some specific GPS devices cause bandwidth issues.

Sounds good. I’ll give that version a try. Thanks sir

Just to close this out- used a generic USB GPS (small mag mount version) and it seems to work fine. Ran it a few hours the other day and all worked reporting to the cloud mapper.