Upload API endpoint not found

Im using latest firmware version krakensdr_pi4_01_March_2024.img.xz .
I’m trying to change settings programmatically via API, which described in official documentation, but, unfortunately, receive 404 error.

Foe example:
I successfully can get settings.json by
But with curl -F "[email protected]"\?path\=/ it returns 404 with next output (basically default 404 page)

root@a7598f0471ce:/srv/app# curl -F "[email protected]"\?path\=/
<!doctype html><html><head><title>404 Not Found</title><style>
body { background-color: #fcfcfc; color: #333333; margin: 0; padding:0; }
h1 { font-size: 1.5em; font-weight: normal; background-color: #9999cc; min-height:2em; line-height:2em; border-bottom: 1px inset black; margin: 0; }
h1, p { padding-left: 10px; }
code.url { background-color: #eeeeee; font-family:monospace; padding:0 2px;}
</head><body><h1>Not Found</h1><p>The requested resource <code class="url">/upload?path=/</code> was not found on this server.</p></body></html>

What could be wrong?
Thank you.

ok, it looks like en_remote_control in settings.json must be true, but once I change it and restart system it returns to false…

ok, looks like I need to install miniserve, but it throw exception
invalid type: unit variant, expected string only for key profile.release.strip

ok, to solve this issue we need to uninstall rustc if you installed it with apt, as readme file tells us. Problem that apt installs 1.46 version, very old, even after update.

  1. apt remove rustc
  2. sudo raspi-config to extend /dev/root
  3. curl --proto ‘=https’ --tlsv1.2 -sSf https://sh.rustup.rs | sh to install latest rustc
  4. cargo install miniserve

but still upload endpoint 404

ok, investigating…
changed user and group for _shared folder from root to krakenrf
If I run ./kill.sh and ./gui_run.sh - all works (except UI), now need to understand why it does not work during normal startup

issue solved.
miniserve was in PATH for krakenrf user, but not for root.
sudo cp /home/krakenrf/.cargo/bin/miniserve /usr/local/bin/
solved this issue. now remote control works even after hard reboot.