Unable to Initialize (VM Image on Windows 11 Host)

It’s possible I am a complete moron, but I’m unable to get connected to the DAQ while running the VirtualBox image on a Windows 11 host. Is there anything that isn’t readily documented that I might be missing? Additionally, can someone advise if any drivers are required on the host, in order for USB pass-through to work? I am assuming not since VirtualBox sees the raw device in the filter page.

Any help is appreciated; thanks.

Double check that your USB settings in Virtual Box are set to USB3.0, and that your Virtual Box version actually supports USB3.0, and that you downloaded the extension pack which enables USB3.0.

The Kraken is a USB2.0 device, but for whatever reason only the USB3.0 stack in VirtualBox is fast enough and doesn’t drop samples.

You don’t need USB drivers on the host.

Finally also check that it is not a problem with the USB ports on your PC. Make sure you are using the high quality ports at the back of your PC, and also that you are using a short high quality USB cable. Also that your power supply is sufficient.

Thanks Carl! The best I can tell everything was fine on VirtualBox; I tried it on two separate machines as well. I also tried different USB cables - and power supplies. Finally, I resorted to flashing a Raspberry Pi and it still wasn’t working properly. However, after running rtl_test or whichever program was suggested in some of the Kraken pages, it finally started communicating. Interestingly, the test actually failed. I have yet to try with USB pass-through again, but when I do, I will report back here in case anyone else encounters this issue.

Thanks again,

1 Like