Trouble getting started

I just recieved my Kraken SDR, I have a decent background working with SDRs from my HackOne RF SDR and Gnu radio, and a decent understanding of computer science (IE: git, programming etc. etc.) However, I cannot for the life of me get this thing running.

I have a Raspberry Pi 4 on hand and originally started by reading through the docs on GitHub and setting that up per the instructions. However, I could not get the Krakwn DOA or any other service running (with exception of the tuner checkout). I checked the obvious culprits such as firewalls, etc., but at this point I am stumped and might return my Kraken…

Any advice on how to get the Kraken running and other resources than GitHub, etc. would be greatly appreciated.

Are you using as a mobile or base application? Some features won’t act like they work until you are moving around.

I needed to read the “how to” forum more then once to fully see what i was missing. A lot can be overlooked. :face_with_monocle:

The UI does have a learning curve in my opinion, but this forum is very useful. I did have to set mine up in my radio room first just to get familiar with basic operation while i had the 'how to" open.

This site has proven to be very helpful to me. If you still have issues, post a more elaborate explanation to the problem so someone with more insight may be willing to reply.

At the moment I am just trying to get an output in GNU radio to make sure the kraken is even functioning. However, at the moment, the OOT block simply says Port is not connected. I double checked the network settings in the OOT source block and everything appears to be configured correctly, but it is still not working.

Start with the Pi4 image and ensure that you are on the same network when trying to connect to it’s IP. Let us know the full details about your setup and exactly what you have tried for better troubleshooting.

1 Like

Thanks Carl; I have a similar/same problem.

My configuration:
KrakenSDR ----usb— Pi4
KrakenAndroid hotspot on Android phone
Pi4 connects to hotspot (Tick)
Laptop connects to hotspot (Tick)

Connect laptop browser to IP_Address:8080 ===> KrakenSDR config screen displayed
But…connection status is “Disconnected”, Frame Index is not incrementing.

Advice appreciated.


The post about power supplies encouraged me to check there.

I switched the two power supplies around and restarted the KrakenSDR and the Pi4…and presto, it works! I was aware of the need to provide good power for the KrakenSDR and purchased what I thought was a good quality car adapter. I connected to the Kraken using a Soopii cable (the ones with the power usage readout on the end of the cable).

I will experiment to see if the issue is the cable or the 12V car adapter.

Back soon…

I was finally able to get up and running on the Raspberry Pi. However, this is still less than ideal for my deployment scenario, and I would prefer to run it on a VM on my laptop as this is a more mobile and powerful solution.

Regarding your questions, Carl, I set the Raspberry Pi on my local wireless network by modifying the wpa_supplicant.conf file, fixed the avahi-daemon.conf for mDNS, and use those to connect directly.

Regarding the virtual machine, I am running Kali Linux ARM distro on my laptop (which has an apple silicon chip). The USB passthrough is functioning well so far as I can tell, as the command line tuner tests all check out fine, as do the USB speed tests I have tried. Where I am encountering issues is regarding a strange case where various scripts in the startup files are not executing.

Has anyone successfully managed to start the Kraken DOA or GNU radio plug-in running on Kali? Taking a look at the GNU radio plug-in, is it possible to run GNU radio on a separate machine and access the IQ server over LAN?

Can you check the log files in heimdall_daq_fw/Firmware/_logs and krakensdr_doa/ui.log for errors or missing package errors?

Yes you could run heimdall on the Pi4, and the GNU Radio script on another machine. BUT it’s a lot of data to transfer, so gigabit connection on a relatively quiet network is required.

I managed to get it working both on the pi and on the VM. There is a bottleneck when running on the VM or the IQ data over the network, however, as Carl mentioned.