Pi Image v1.8.0 unable to set 4 RX Channels


After upgrading to 1.8 image from 1.7, I do the typical procedure to adjust it for KerberosSDR, that is, loading the “Preconfigured DAQ Files” called “kerberos_default”. It seems to load and save, but “# RX Channels” always stays con 5. Tried to manually adjust it to 4, but no way. It always goes back to 5.

Also, if the Kerberos preset is loaded, seems like it can not connect to the Kerberos (the left area “DAQ Subsystem Status” shows error “Empty/Unknown (likely failure)”). If I load “kraken_default” at least it will something (but not fully OK like in the 1.7).

Back to 1.7 and configured everything with success with a couple of clics.

I am not sure if I am doing anything wrong, but I would say no. Any idea? Of couse, I can help testing with whatever you suggest.

Best regards.

Hm nothing should have changed in regards to heimdall between versions. Did you remember to click on the reconfigure and restart button after changing to Kerberos?

Are you able to SSH into the image, and try to set the settings manually via the daq_chain_config.ini file?

Hello and thanks for your response.

Yes! I clicked “Reconfigure & Restart DAQ chain” like 20 times. I reinstalled the image as well, etc… The same procedure works in 1.7 but not in 1.8.

I tried to manually edit the “daq_chain_config.ini” and it seems to work. At least the DAQ Subsystem Status shows all green as usual (didn’t test in fild). So I think the Web Interface is not saving. Maybe is a browser related problem? I am using Firefox

This is how the interface looks after selecting “kerberos_default” and pressing “Reconfigure & Restart”

Then perform a manual reboot and… not working

The daq_chain_config.ini seems not perperly configured.

What else do you want me to test?

For now you can manually edit the ini file for kerberos by copying heimdall_daq_fw/config_files/keberos_default/daq_chain_config.ini into the Firmware/ folder, and overwriting the daq_chain_config.ini file in there already.

I’ve added a node to look into why the reconfigure button has stopped working in the latest version.