Pi 4 alternative

hi everyone

will this SBC be a good replacement for the PI 4

NanoPi R6C


NanoPi R5C


Same chip as the Orange Pi 5, which works great. Assuming their USB implementation on the board is good, it should work well.

1 Like

thx ,
i’ll order one , and get a pcie wifi card with it.

How well did this device work for you? Would you recommend it to others, considering the rpi4 shortages and all?

@Robert.ad6xj We have the Pi 4 in stock and ready to ship.

1 Like

ordered the Orange Pi 5B
just got it
trying to boot krakenrf image form SD
seems its always defaults to Emmc
if anyone has any tips , plz share
working on it now

good video (2nd half) explaining how to load the Image to Emmc

krakenRF didnt work, the shared ubuntu worked

the ubuntu image Releases · Joshua-Riek/ubuntu-rockchip · GitHub

should enabled me to boot from SD or USB (krakenrf on SD / usb ) didnt load

in progress

progress report on the Orange PI 5B

using etcher
img from OrangePI site boots form SD card
img from KrakenRF fails to boot

board stays in red red light status.

used OprangePI SDDiskTool to create a boot usb,
tool fails to read the Krakenrf Img file.


at this stage , will try using the install script to see if it complete successfully.

will continue to search on ways to get the Kraken img file to boot from SD

There is no Orange Pi 5 img for KrakenSDR yet. The image provided is only for The Raspberry Pi4.

yet , i like yet
thought i can use the same img
any steps to take to make it work , or it has to be re-build ?

Please try using the installation scripts again, they were just updated. A third party package called numba updated, and the script automatically pulls the latest version. Unfortunately the latest version has an issue which causes our code to fail. This has been fixed in our new script update now.

i tried the scripts couple of days back on OrangePI ubuntu img

completed but failed to start

i’ll try the updated script on Joshua-Riek img , since its on the emmc now

will keep you posted

one more thing

do i need to run other installation steps post the scrip , after activating kraken environment on conda ?

No the script should do everything. After the script, reboot, then just run ./kraken_doa_start.sh

used the below

wget https://raw.githubusercontent.com/krakenrf/krakensdr_docs/main/install_scripts/krakensdr_aarch64_install_doa.sh
sudo chmod +x krakensdr_aarch64_install_doa.sh

it installed the files on /root

scripts runs

  1. :~/krakensdr_doa# ./kraken_doa_start.sh

  2. Shut down DAQ chain …

  3. Config file check bypassed [ WARNING ]

  4. kernel.sched_rt_runtime_us = -1

  5. Desig FIR filter with the following parameters:

  6. Decimation ratio: 1

  7. Bandwidth: 1.00

  8. Tap size: 1

  9. Window function: hann

  10. FIR filter ready

  11. Transfer funcfion is exported to : _logs/Decimator_filter_transfer.html

  12. Coefficients are exported to: _data_control/fir_coeffs.txt

  13. Starting DAQ Subsystem

  14. Output data interface: Shared memory

  15. ) (

  16. ( ) )

  17. ) ( (

  18. ______)

  19. .-'---------|

  20. ( |/////|

  21. '-./////|

  22. ‘_________’

  23. ‘-------’

  • Have a coffee watch radar
  1. Starting KrakenSDR Direction Finder

  2. Web Interface Running at

  3. PHP Data Out Server Running at

but web interface is not loading the page

installation log

There’s a problem here in the heimdall install.

But another question is why did it install to /root?

Did you run the script from the home directory, or from /root ? If not the home directory, try delete all the folders it installed and start again with the script in the home directory.

Cloning into 'heimdall_daq_fw'...                                               
remote: Enumerating objects: 1343, done.
remote: Counting objects: 100% (588/588), done.
remote: Compressing objects: 100% (165/165), done.
remote: Total 1343 (delta 432), reused 495 (delta 382), pack-reused 755
Receiving objects: 100% (1343/1343), 1.96 MiB | 3.55 MiB/s, done.               
Resolving deltas: 100% (860/860), done.                                         
cp: cannot stat '/root/librtlsdr/build/src/librtlsdr.a': No such file or directory                                                                              
cp: cannot stat '/root/librtlsdr/include/rtl-sdr.h': No such file or directory  
cp: cannot stat '/root/librtlsdr/include/rtl-sdr_export.h': No such file or directory                                                                           
gcc -Wall -std=gnu99 -march=native -O2 -I. -c -o ini.o ini.c                    
gcc -Wall -std=gnu99 -march=native -O2 -I. -c -o log.o log.c                    
gcc -Wall -std=gnu99 -march=native -O2 -I. -c -o iq_header.o iq_header.c        
gcc -Wall -std=gnu99 -march=native -O2 -I. -c -o sh_mem_util.o sh_mem_util.c    
gcc -Wall -std=gnu99 -march=native -O2 -I. log.o ini.o iq_header.o -o rtl_daq.out rtl_daq.c -lpthread -lzmq  -L. -lrtlsdr -lusb-1.0                             
rtl_daq.c:49:10: fatal error: rtl-sdr.h: No such file or directory
   49 | #include "rtl-sdr.h"
      |          ^~~~~~~~~~~
compilation terminated.
make: *** [Makefile:31: rtl_daq] Error 1
1 Like

Also I see you ran

sudo ./krakensdr_aarch64_install_doa.sh

You need to run the script without sudo.

1 Like

thank for all the support
followed your instructions and its running on the Orange5B now

below is a screenshot of usbtop command with the speeds