Known good USB and power supplies

Hello all,

I have had the hardest time getting my krakenrf to work.

I’ve tried it with many cables for both data and power, and all kinds of power supplies. I’ve also tried it using an RPi4, on a Linux PC, Linux laptop with a fresh OS install, and the virtual machine on both PC and laptop.

I just can’t get the kraken to connect to the software.

At this point I have to think it’s due to USB or power.

What are some cables, DC supplies, or batteries that you have used that worked well?

What is the current-rating of your power supply?

Have you tried powering on in stages? Try powering the kraken, wait about a minute, then power the pi4. I am using 2 pi4 power supplies. 1 for each device without an issue.
I am also using a pure sine-wave inverter to power the 2 pi4 power supplies in my vehicle with same setup and no problems either.

1 Like

Using Anker 337 battery which has 5V, 6A total with 3A per port.

Edit 2:
No difference when used with a monoprice QD power supply or standard monoprice power supply.

Always using one power supply for one device.

I have been powering them with completely independent power supplies but I will try this.

Late breaking update:

Cables that don’t work for data:
Anker 1ft braided
Monoprice 3ft braided (worked intermittently)
Monoprice VW-1
Google pixel USB A to C cable
USB SuperSpeed

Cables that worked for data:
Choetech 1ft braided

Seems odd that so many USB-C cables aren’t working for you. Back in the KerberosSDR days a lot of cheap microUSB cables wouldn’t work, but now that we switched to USB-C I’ve only ever come across one cable that couldn’t handle the high data rates, since USB-C cables are usually built to a better standard.

If possible try another Pi 4 or another USB port on the Pi 4. The Pi 4 USB ports themselves do sometimes become dirty/rusty or just faulty and that can cause issues.

Also please make sure you’re not just confusing the initial startup delay with it not working. On the first ever boot it could take a couple of minutes of waiting before any activity starts to show up on the web GUI.

I’m giving the whole setup about 10 minutes to settle each time when I test a new cable or power source so it takes me a while to test everything hahaha.

The Pi4 has been the most successful of all the software hosts with the virtual machine in second place.

Interestingly even when the software refuses to connect, sometimes I’m able to see the tuners with rtl_test when I ran it on Linux pc/laptop.

Going to get more cheotech cables and test with other software hosts.

When I was getting started, I connected a monitor to the Pi to watch it boot up. If you haven’t tried that, you might give it a shot. There are alot of messages displayed on the console during the boot phase. You might see what’s going on.

If you add a keyboard, you can log into the Pi and see if the Kraken is connected by looking for its USB devices. You should see 6 USB devices (IIRC) if the Kraken is connected and running. I don’t have one in front of me and I can’t remember exactly, so someone please correct me if I’m wrong.

That should tell you if the Pi is running and if the Kraken is running, or give you a clue where to look next.

I know the pi works because I can SSH into it.

I haven’t had a chance to try anything else out yet.

I pulled my hair out trying to resolve flaky mobile operation and hangs using a variety of 12V USB-C adapters and C cables. It seemed to be power issues with the Pi4. Once I tried a **DC Buck Module, DROK Adjustable Buck Converter Step Down Voltage Regulator 6V-32V 30V 24V 12V to 1.5-32V 5V 5A LCD Power Supply Volt Reducer Transformer Module Board with USB Port Protective Case (Amazon) and SET TO 5.1-5.2VDC, the problems seemed to clear up. I don’t have a lot of hours on it yet (antenna/coax failures :rofl:) and it’s not my long-term solution, but maybe worth a try.

Yes if the power supply for the Pi 4 is not sufficient, then the Pi 4 is going to throttle it’s CPU a lot, or even crash.

If you’re using an inverter, lots of switching power supplies get mad at non pure sine wave AC. Just a thought.

Just curious how the results are so far? I have been battling with this same issue. Had a fox hunt the other day and everything just went south. I’m going to try that route- 12v directly to the DROK (one for the PI4 and another for the Kraken). Hoping that solves it. When it’s working- it’s amazing. When it gets irritable, total mess. On a bright note- we did win the fox hunt after multiple reboots and a few minutes of working.

I’m actually going forward with quite a similar setup.

I’m obtaining some LiFePO4 cells to build out a kraken specific battery pack.

I’ll report back when I know if it makes things better or worse, lol.

As of right now my most stable setup is a choetech or Anker cable of the shortest variety they sell, hooked up to an Anker USB-C PD 3.0 capable powerbank.

I made some adjustments this week. Added the image to a SSD for a direct boot. Added (2) DROK Bucks (1 for the PI, 1 for the Kraken). Going to see how it does over the coming weeks. Next step is the battery solution for a nice stable voltage. Will report back

Monoprice cables work great for power, but will not function for data.

Not sure why…

Data seems much pickier than power.

Updated list since I apparently can’t edit the OP

Cables that don’t work for data:
Anker 1ft braided
Monoprice - ALL
Google pixel 4 USB A to C
USB SuperSpeed

Cables that worked for data:
Choetech 1ft braided
Google Pixel 1 USB A to C