Help with Kraken not seeing any signals

I have made a box for my Kraken SDRwhich gets hooked up to a 5V buck converter that is attached to my 12V battery box. Also attached to this is a 5V buck converter going to my Jetson Nano which runs the Kraken Heimdall DAQ and whatnot. I tried both on my Linux laptop with ethernet connection to the jetson nano, and with a screen attached to the jetson nano, and on GNU Radio the FFT display I only see the noise floor, even when I key up an HT on VHF or UHF frequencies (and adjusting the frequency in GNU Radio).
I tried attaching antennas to multiple outputs on the KrakenSDR and have seen the same issue. Any help would be appreciated and I can clarify further if necessary, Thanks!
(Note: I also have a Pi 4 that I could use, but would prefer to use the Jetson Nano, might try the Pi when I have some time tomorrow just to see if the same issue occurs)

First, please be very careful transmitting with a HT near the KrakenSDR antennas as this could overload the device and cause it to break. The max input power allowed is +10dBm.

Assuming the HT didn’t damage the front end already, have you played with the gain settings? Can you try with simple SDR software like SDR++?

I was curious how to use the Kraken SDR with SDR++ or MATLAB since on my Windows laptop it shows up as a “Generic USB Hub” and I can’t do much with Zadig for that. I wasn’t sure how to access the individual RTL-SDR ADCs onboard. Thanks for the help and yeah probably should have looked more into the max input power before trying my HT, hopefully didn’t destroy the LNAs on the front end.

On Windows you can simply use Zadig as if you were installing individual RTl-SDRs. Just make sure you and List All Devices enabled, and also Ingore Composite Hubs unchecked.

Might have just played myself, not really certain, just had to reset the drivers and redo Zadig and that part works I see what you mean you just get the 5 bulk interface devices easily. Not sure what was going on with GNU Radio might look into that again and retry it.

I still don’t understand why I could be seeing a signal and when I try it on my jetson nano (same channel 0 of the kraken SDR) I see nothing on the FFT frequency plot in GNU Radio. I am receiving noise floor so Heimdall DAQ is working I would assume otherwise I would receive an error if I’m not mistaken. Any ideas why it would not work in GNU Radio? I want to get it to work there because the scripts I have obtained are meant for a linux environment that utilizes the IQ recorder from GitHub - krakenrf/heimdall_iq_rec at development where my goal is to get these IQ samples into MATLAB which I obtained another tool for VEGA_database_tools/ at master · petotamas/VEGA_database_tools · GitHub but pretty sure these rely on GNU Radio block working with my Jetson nano which currently it is not. Any help appreciated TIA!

Are you using our GNU Radio scripts to try and receive? Did you set the frequency? Please attach a screenshot as that might help.

Also just in case you didn’t know, in Kraken GUI the FFT display actually uses channel 1, not channel 0. This does not affect anything to do with the GNU Radio scripts though.