Get Kraken logs from Raspberry Pi 4

Hello. Recently, I received 2 sets of KrakenSDRs with antennas. Following the manual, I connected everything all together, but I had a few problems. One of them is that when you switch frequency via the web interface it is not updating on the left side and the device/package status changes to LOSS. Page reloading, as well as rebooting both Raspberry and KrakenSDR does not help. I’ve tried to change a Kraken head too, with no effect. So far, the only thing that helps is the re-burning of the SD card used by Raspberry. It resolves the issue until it randomly appears again in an hour or two.

I would like to connect to the Raspberry and check the error logs if any. I assume there are some scripts that could be failing and want to find the cause. Could you please tell me where should I look? Thank you

P.S. SSHing to the Raspberry and restarting the DOA script helps, but only until the next frequency update

Are you powering the KrakenSDR by the Pi or using a separate power source?

I use a separate power source, the original Raspberry one for Raspberry Pi, and a charger from my laptop (USB Type-C, around 5A) for the Kraken. I have also tested another 3A power adapter, with no luck. Also, I have tested 3 different data cables.

I have noticed that if I decrement the default frequency in web UI (416,588) by, for instance, 1 MHz it re-calibrates fine, but when I reduce it by 100 MHz it disconnects as on screenshot above

Have you tried decimating at all?

What do you mean? Could you please be more specific

I have SSHed to the Raspberry, stopping and restarting the helps, but only until the next frequency update

Look for an option that says something about decimation and increase it to like 10. Also try increasing your gain.

I’ve tried and it worked, thank you. Should I now find a decimation value low enough to keep the issue away?

Yeah, you could. I think the problem may have been just too weak a signal and too low a threshold.

Edit: To add onto that, for some reason it would seem your Pi4 is working harder than it should be.

What do you mean by harder?

Try looking at the logs in



Anything interesting after a retune?

I have enabled logging but did not find anything interesting among the logs. Will double-check. Also, the problem was solved by setting decimation value to 10

If you’re using the Pi4 image on a Pi4, I don’t see why setting decimation to 10 would fix things. Could your Pi 4 be throttling and getting too hot for some reason?

This is what I was meaning by working harder @DrunkP . For some reason the Pi4 isn’t able to process all the data and decimating reduced the input dramatically letting it get back to working as intended.

I have tried to reduce processor frequency by 100 MHz by adjusting the boot config, with no effect, also I have set up a small cooler that came with a Raspberry Pi case with the same result, so I have doubts that it is throttling. I’ll double-check though. Nevertheless, I thought that throttling will result in just a slowdown, not disconnection of the Kraken

It should just result in a slowdown, but if it’s so slow that it’s dropping USB samples constantly, then it could disconnect. Pi4’s rarely throttle though even without external cooling due to good thermal design. So I don’t understand what could be special about yours.

Hi, I am having a similar problem with my KrakenSDR that DrunkP experienced. When I first received it, I tested it out on my bench and it was working great, I was receiving frames and everything looked good. On my bench, I used the same two 12v to 5v (3A) USB adapters I use to power other pi 4 in the field.

I transferred everything to my vehicle and it was working well for the first 45 minutes. I was able to quickly find a local ham radio repeater. I then went into the KrakenSDR server settings page and changed the RF receiver center frequency setting to another frequency in the same band. That is when I lost all communication with the KrakenSDR. I brought everything back to my bench and for the last 2 days and several hours I tried various combinations of the following:

  • Stopped and restarted the
  • Set DSP Decimation to various values up to 10
  • Tried adjusting the RF Receiver Center Frequency to other frequencies in the same band and other bands. Changes no longer “stick”.
  • Tried all levels of Receiver Gain. Changes no longer “stick”.
  • Re-flashed the SD card with a clean version of Kraken 1.3 and 1.31 images multiple times.
  • Overclocked the pi 4 to 1750.
  • Tried every USB port on the pi, including the USB 2.0 ports.
  • Swapped out the pi 4 (4GB) with another pi 4 (4GB)
  • Swapped out each Anker USB cable with different brands
  • Swapped out the 5v power supplies with other 3A models, including the pi 4 AC adapters rated at 3.5A.

None of these worked. The KrakenSDR powers up and the fan spins, but it is now completely unresponsive, displaying no blue status lights on the back when the pi is booted, and the server settings always display a red “Disconnected”.
On the pi, every rtl_test for -d0 through -d4 now always returns:
Resource not available

The rtl_daq.log log file has one line in it:
FATAL rtl_daq.c:558: Failed to open RTL-SDR device: Resource temporarily unavailable.

The hwc.log log file contains:
CRITICAL:root: Failed to aquire iq frame, exiting ..

There is no iq_server.log or squelch.log files.

It was working great at one point but is now completely unresponsive. I don’t know what else to try and am afraid my KrakenSDR is somehow bricked. Is there some way to reset it so it is once again visible to the pi, or has it slipped into the deep? Thanks in advance for any suggestions.

This sounds like a different problem to DrunkP. What is strange is the error you’re getting. I’ve never seen that error before.

Do you have a second Pi 4 you can test with? It almost sounds like the Pi4 USB controller has died.

One idea, is to check if this an old Pi4, or a newer one? Can you try upgrading the Pi4 bootloader EEPROM if you never did it on that device? I recall older Pi4 EEPROM versions had some USB bugs. This link explains the problem and how to update the Pi4 EEPROM: How to fix Raspberry Pi 4 USB stack

I think the Pi4 bootloader EEPROM with the USB bug will not be updated even when booting from a newer image like ours, since that EEPROM is internal to the Pi4 itself.

If that doesn’t help, can you connect the Kraken to a PC, and confirm with SDR# or similar software that all tuners work normally there?

Thanks for the suggestions, Carl. Clarification… when I run rtl_test -d0 through -d4, I receive the response:
No supported devices found, not resource not available.

I did try a second pi 4 (4GB). This second pi 4 I currently use with a FlightAware ADSB receiver which it’s been working properly with no issues for months. There is no difference, the KrakenSDR is not visible and rtl_test still returns no supported devices found. Update: the pi 4 (4 GB) I use for the Kraken is a recent model purchase last spring from Canakit, when they were still in stock.

I updated the Pi 4 EEPROM as suggested and still no difference.

I connected the KrakenSDR to two different Windows PCs both which I’ve regularly used with SDRuno and SDR# with other SDRPlay Duo and RTL-SDR devices. In both cases, the KrakenSDR is not visible and does not display in Device Manager.

Is it possible something failed on the Kraken board? I’ll be happy to ship it back for evaluation and possible replacement.