Enable DoA Estimation

Hi everyone, I hope to find an answer thanks to you.

I’m working on a project to use the KrakenSDR device to identify different jamming sources. I wanted to test the tracking option with a transmitter with a known location, in order to see if I can eventually find it. However, I’m encountering a problem with the configuration. When I enable the option “Enable DoA Estimation” and observe the spectrum, it completely freezes, and DoA Estimation doesn’t work. When I deactivate it, the spectrum unfreezes.

Does anyone have an idea where this issue could be coming from?

Thanks in advance!

Are you using the pre-made image, or self install? What is your computing system?

The Enable DoA Estimation check box is enabled by default.

You can try checking the log files in krakensdr_doa/_share and heimdall_daq_fw/Firmware/logs so see if it mentions any error when you click on the button.