DOA Start Script Multiple Errors

Looking for some help on what is hopefully just a user error. I installed the DOA software via script to a fresh RPi OS install, following the instructions in the Wiki. Rebooted and ran the start script, but I’m getting the following output:

./ Line 4: conda: command not found
./ Line 5: conda: command not found
Shut down DAQ chain …
Config file check bypassed [ WARNING ]
kernel.sched_rt_runtime_us = -1
Traceback (most recent call last):
File “/home/krakenpi/krakensdr_doa/heimdall_daq_fw/Firmware/”, line 16, in
from scipy import signal
ModuleNotFoundError: No module named ‘scipy’
DAQ chain not started!
Starting KrakenSDR Direciton Finder
Web Interface Running at
PHP Data Out Server Running at

I’m a Linux noob, and my limited poking around and Googling didn’t uncover anything particularly relevant as a starting point to attempt to resolve this. Any help would be greatly appreciated.

Could you try downloading and burning the image?

I’ve got a separate microSD card with the official KrakenRF image, but I’m not planning on pairing with an Android device for now, so I was hoping to use the clean RPi OS image as a basis for more learning and experimentation.

That indicates that the conda install failed on your system for some reason, and hence everything after fell apart. How big is your SD card? I believe the conda install will need at least 16GB for temporary files.

The card is a 32GB, and I show that I still have 26GB remaining. That said, I did run into an issue with the pre-built KrakenRF image where when I burned it with the RPi Imager tool, the partition wasn’t occupying the full disk space. I had to expand it after the fact - found out when I was installing VNC Server for remote access.

Given it’s likely just the conda fail, I’ll reimage the OS again and re-run the install script. Will report back, thanks!

Quick update, seems like it failed again. I need to scroll back through the terminal window for the install script to see if any errors stand out.

There’s a lot to unpack and apparently the default terminal scrollback limit is 1000 lines. Going to do another clean install and increase that limit before I run the install script.

Took screenshots of the various errors that I saw and put them into an imgur album.

Edit, had a few minutes to really read through the errors. It seems like the conda issue is stemming from the fact that the Miniforge3 package has a .exe file in it that Linux isn’t able to utilize.

Edit2, decided to try following the instructions for a manual install. When installing the Ne10 DSP library, I still get a ton of:

error: inlining failed in call to ‘always_inline’ '<many different number types> ’ : target specific option mismatch

What version of Raspbian have you installed? Could it be that you installed the 32-bit version instead of the 64-bit version?

The installer is assuming that you are using the 64-bit Raspbian.

That’s exactly what it is. I feel like a massive idiot. The official Raspberry Pi imager defaults to the 32-bit image, and you have to intentionally go grab the 64-bit version.