Decorrelation = On, Spatial Smoothing MUSIC algorithm, DAQ Subsystems gets no update anymore, V1.7.0

Kraken System V1.7.0 up and running, ready for a car measurement drive. This means configuartion site updating every more or less second with actual data, spectrum site running with actual data, and finally also DOA estimation shows some bearing results. Last change was, I changed parameter “Decorrleation = On” and I choose “Spatial Smoothing” as MUSIC algorithm and set “expected number of RF source = 3”. Then I switched to configuration site and saw Update Rate 54.00 s, Latency 161919 ms, Frame in Index 1003, no updates anymore. This issue happened twice this afternoon.

I had to power off/on KrakenSDR and Pi4 for a restart. With system up and running, changing finally parameter “Correlation = On” and MUSIC algorithm “Toeplizfication” or “F-B Toeplitz” and “expected numbers of RF sources” the system runs. Can you please analyze and send an advice?

Spatial smoothing is quite hard on the Pi 4 CPU, and the first time it runs the numba cache will take several seconds to build, and during that time it could like like it crashed. It’s possible that maybe something glitched during the numba cache compilation though, which is why you’re never recovered.

If you’re on a Pi 4 I would just recommend sticking with the standard MUSIC algorithm, or if you want to test, something low on CPU usage like Toeplitz.