DAQ issues on Orangepi4lts

I am trying to get my Orangepi4lts to cooperate, and I am throwing my hands up in the air. I am using the barrel plug for power, and connecting via the USB3.0 port. I can get the kraken_test script to see the devices. My issue is stemming back to the DAQ not initializing, and I think I’ve pinned it down but I don’t know why or how to fix it.

Here’s the images I’ve tried so far:
I have tried both the aarch64 install script, and manually installing. It installs, and I’m able to start up the server on both images. For some reason, when I install manually on Ubuntu, and in all situations on Debian, I can’t get both port 5000 and 5001 to open (Debian won’t open port 5000, but will open 5001. Ubuntu manual install will open 5001, but not 5000). Weird, but I’ve got it working finally from the install script and I’m able to connect via my hotspot on Ubuntu, great.

Problem is, DAQ won’t connect. it shows Frame Sync LOSS and DISCONNECTED in friendly red letters. not great.

Ok, let’s take a step back, I never tested like the instructions told me to! I shut it down and try to use the unit_test.sh script:

(kraken) orangepi@orangepi4-lts:~/krakensdr/heimdall_daq_fw/Firmware$ ./unit_test.sh
Start unit testing…
Internal warnings are ignored
./unit_test.sh: 5: cannot create /dev/NULL: Permission denied
./unit_test.sh: 6: cannot create /dev/NULL: Permission denied
test_decimator (unittest.loader._FailedTest) … ERROR

ERROR: test_decimator (unittest.loader._FailedTest)

ImportError: Failed to import test module: test_decimator
Traceback (most recent call last):
File “/usr/local/lib/python3.8/unittest/loader.py”, line 154, in loadTestsFromName
module = import(module_name)
File “/home/orangepi/krakensdr/heimdall_daq_fw/Firmware/_testing/unit_test/test_decimator.py”, line 35, in
from scipy import signal
ModuleNotFoundError: No module named ‘scipy’

Ran 1 test in 0.001s

FAILED (errors=1)

Here’s where I’m stuck. Miniforge has Python3.9 installed in the env, and scipy is in its site-packages. I also have no idea why it says I don’t have permissions to creat /dev/NULL.

(kraken) orangepi@orangepi4-lts:~/krakensdr/heimdall_daq_fw/Firmware/_logs$ python -c “import sys; print(‘\n’.join(sys.path))”

(kraken) orangepi@orangepi4-lts:~/krakensdr/heimdall_daq_fw/Firmware/_logs$ ls /home/orangepi/miniforge3/envs/kraken/lib/python3.9/site-packages | grep “scipy”

I’m suspecting what I’m running into is a conda issue, and this is keeping the DAQ from initiating properly. What do y’all think? I’m concerned that this may lead to more bugs as I fix this problem. I see other people have been successful getting their orangepi4 to work, but I’m not sure what the difference is here. Thanks in advance for any brainstorming ideas y’all can come up with!

The unit test isn’t configured for users to run easily, it’s just something we’ve been using internally.

Please try running the actual code, and then pasting the output of the logs.