Why does my unit seem to be flaky?

I don’t know if the image on the PI is corrupt or the SDR has gone bad, but this is driving me crazy.

First, got the unit working great until it didn’t. Went to reinstall the IMG to the SD card and found a corrupt SD card. This progressed as the web interface worked but wouldn’t connect to the SDR.

Replaced the SD card and wrote the latest image.

Used it a week later, used it for about 4 hours, and it worked great. Powered it on today and now I am getting the same behavior as I did before, the web interface comes up, blue lights on the SDR but all red. Every once and a while, everything will show green except for Sample Delay and IQ Sync. WTF…

Blue lights are on, web interface comes up. no data.

I am not a Linux guy and this if so rough when trying to track time sensitive interference.

Would love ideas and elementary steps to test and verify.

I have swapped USB cables as well. Again blue lights but no function.

What’s your Pi 4 power supply like? I have seen Pi 4’s continuously corrupt SD cards before when they were on really noisy power supplies.

If you can also try SSH into the system and run the troubleshooting steps on the Wiki 07. KrakenSDR Troubleshooting · krakenrf/krakensdr_docs Wiki · GitHub


Thank you for your insights to why I’m struggling. I was using an invertor powering AC high powered USB C power supplies. I replaced those with a 12volt to USB power device and seems to be working so far. Please pardon my frustration as I was in the heat of tracking an amateur jammer.

An inverter could definitely be the cause of troubles as the output from them can be very noisy.